Frequently Asked Question
Some Need4Viz charts are not displayed in Web Intelligence documents (split deployment)
Dernière mise à jour il y a 5 ans
Symptom
- Some Need4Viz charts are not displayed in Web Intelligence documents (blank cell)
- Other Need4Viz charts are displayed correctly (vertical table...)
- Other Need4Viz charts are displayed incorrectly (Filter table chart)
Reason and Prerequisites
Environment:
- SAP BusinessObjects Business Intelligence Platform all versions
- Need4Viz : all versions
Steps To Reproduce:
- In a Webi report, configure a new Need4Viz chart (Drillbar chart)
- When validated, the chart is not displayed (the cell stay blank)
- Turn the chart into Need4Viz Vertical scroll table
- When validated, the chart is displayed correctly
Cause:
- This issue is caused by a problem of misconfiguration of the product on some servers because the Web server is not correctly configured in the parameter of the need4viz server.
- The URL to configure must be the one that users are accessing from their computer
Solution
1.Check the deployment of Need4Viz webapp on your boe Tomcat
Ensure the URL that you fill is working from a user perspective
- Open a web browser (I.E. Chrome) and go to the URL your_boe_server_url/N4VCustomElements/res/images/green_tick.png
- The following green tick should be displayed
2.Edit the config.js file in
~installation_BOE_Folder\nodejs\node_modules\custom_element\ce_libs
Change the following settings
Example for a standard SSL configuration
var URLNodeJSServer = 'https://your_boe_server_url';
var PORTTomcat = 443;
Example for a standard non-SSL configuration
var URLNodeJSServer = 'http://your_boe_server_url'';
var PORTTomcat = 80;
3. Then stop and restart Need4Viz services.