Frequently Asked Question
Previous chart settings are not displayed after a migration on a new Need4Viz server
Last Updated 3 years ago
Symptom
- Need4Viz was previously installed on a first server (for instance in a SAPBI 4.2 environment) and dashboards have been designed with Need4Viz components
- A new server is installed with a full setup of Need4Viz (for instance in a SAPBI 4.3 environment) and the BO reports are migrated from the previous installation to the new one.
- When opening the dashboards in the new SAPBI environment, the Need4Viz components are correctly displayed but when opening the setting parameters, all the custom parameters are re-initialized (for instance, the title setting of the chart is empty and trying to set a new one has no effect).
Reason and Prerequisites
Environment:
- SAP BusinessObjects Business Intelligence Platform all version
- Need4Viz : from 2021.4.1 full setup installation
Cause:
- A new general configuration setting has been added in the 2021.4.1 version (and upper). This setting give the ability to keep common parameters between Need4Viz charts (of a same category) when doing a "turn into".
- This setting cannot be activated when previous version of Need4Viz have been used.
- This setting is automatically set when installing a full version of Need4Viz (from the 2021.4.1 version).
- During a Patch installation, this setting is not changed (all patchs applied on a full setup keep the previous value)
Solution
Considering a source environment with a Need4Viz installation (for instance SAPBI 4.2) and a target environment with a new Need4Viz installation (for instance SAPBI 4.3). After installation of Need4Viz full setup in the target environment :
- Open the ~Need4Viz_folder_installation/nodejs/node_modules/custom_element/ce_libs/config.js file in the source env.
- Check the value of the Use_Common_RegId setting (true or false)
- Close the file.
- Open the ~Need4Viz_folder_installation/nodejs/node_modules/custom_element/ce_libs/config.js file in the target env.
- Set the value of the Use_Common_RegId setting with the same value as in the
source env (probably "false")
Save and close the file
- Restart the Need4viz server in the target env. with the script ~Need4Viz_folder_installation/scripts/Start_Need4Viz.ps1 in a PowerShell window
- Open a migrated dashboard in the target env. and check the settings of a Need4Viz component, they should be correctly displayed now.