Frequently Asked Question
Symptom
- Some Need4Viz charts are not displayed in Web Intelligence documents (blank cell)
- Other Need4Viz charts are displayed correctly (vertical table...)
- Other Need4Viz charts are displayed incorrectly (Filter table chart)
Reason and Prerequisites
Environment:
- SAP BusinessObjects Business Intelligence Platform all versions
- Need4Viz : all versions
Steps To Reproduce:
- In a Webi report, configure a new Need4Viz chart (Drillbar chart)
- When validated, the chart is not displayed (the cell stay blank)
- Turn the chart into Need4Viz Vertical scroll table
- When validated, the chart is displayed correctly
Cause:
- A : This issue is caused by a problem of access to the Need4Viz web application on the webserver (Tomcat). The needed N4VCustomElements webapp folder has probably been set uncorrectly during the Need4Viz installation setup.
- B : The setting of Need4Viz web application server is not correct in the config.js file
Solution
A : Please check the Need4Viz web application is correctly deployed in your web application server.
For Tomcat (or Apache) :
- check the folder N4VCustomElements is in the ~installation_BOE_Folder\tomcat\webapps\ folder
- if not, search the N4VCustomElements or the res folder in your tomcat webapps folder
- move the N4VCustomElements\res folder inside the ~installation_BOE_Folder\tomcat\webapps\ folder
- Open a web browser (I.E. Chrome) and go to the URL
http(s)://your_boe_server_url/N4VCustomElements - The welcome N4VCustomElement webapp page should be displayed
B :
1. Edit the config.js file in
~installation_Need4Viz_Folder\nodejs\node_modules\custom_element\ce_libs
2. Check the following settings
Example for a standard SSL configuration
var URLNodeJSServer = 'https://your_boe_server_url';
var PORTTomcat = 443;
Example for a standard non-SSL configuration
var URLNodeJSServer = 'http://your_boe_server_url';
var PORTTomcat = 80;
3. Then stop and restart Need4Viz services.