Frequently Asked Question
Symptom
- The "Turn Into Custom Element" button and the "Insert Custom Element" item are intermittently greyed out :
Reason and Prerequisites
Environment:
- SAP BusinessObjects Business Intelligence Platform : 4.3
- Need4Viz : all versions
Steps To Reproduce:
- In a Webi report, try to insert a new Custom Element
- or create a webi table bloc a try to turn into Custom Element this block
- The "Turn Into Custom Element" button and the "Insert Custom Element" item are intermittently greyed out
Cause:
The antivirus on the SAPBI server interrupt, during its scan, the communication between SAPBI/Tomcat services and N4V services.
Solution
An SAP note exists about exclusions rules to apply on your antivirus on a SAPBI server : https://me.sap.com/notes/1497394/E
Synthesis of this SAP Note :
Symptom
- When antivirus or security scanner applications are enabled, Business Objects services do not start remaining in initializing status; when antivirus is disabled the services start fine.
- What processes and directories should be excluded from anti-virus software scans and monitoring?
- Anti-virus software scans or security scanners are affecting the performance of the SAP BusinessObjects applications and on the client is leading to other errors
e.g.: login failures from Web Intelligence Rich Client and Crystal Reports Client. - Is there an antivirus or scanner exclusion list?
Environment
- SAP BusinessObjects Enterprise XI 3.1 (Any Service Pack)
- SAP BusinessObjects Business Intelligence 4.0 / 4.1 / 4.2 / 4.3 (Any Service Pack)
- All supported Windows Server versions
- Anti-virus:
- McAffee VirusScan
- Norton Antivirus (Symantec)
- Trend Micro OfficeScan
- Microsoft
- Kaspersky
- Panda
- Cylance
- Blackberry
- Others
Reproducing the Issue
- Install & enable antivirus on BI installation server
- Start BI servers/services
- Validate servers stuck in initializing status or performance issues (check the CPU performance filtered by process)
- Disable antivirus
- Restart SIA and validate servers/services start successfully
Cause
Installed antivirus is blocking SAP Business Intelligence files
Resolution
SAP does not support the configuration or exclusion format of Antivirus software nor performs testing with antimalware solutions with product releases, and further inquiries should be directed to the third party software vendor.
SAP Product Support recommends the following binaries should be excluded from active scanning: %InstallDir%\ and all sub folders :
AAAnalytics.exe
AADashboard.exe
SvcMgr.exe
CMS.exe
ConnectionServer.exe
ConnectionServer.exe (32bit)
crcache.exe
crproc.exe
crproc.exe (32bit)
crystalras.exe (32bit)
EventServer.exe
fileserver.exe
JobServer.exe
JobServerChild.exe
sia.exe
WIReportServer.exe
xccache.exe
xcproc.exe
java.exe
tomcat6.exe
sqlservr.exe
svnserve.exe (32bit)
dbsrv12.exe
dbsrv16.exe
dbsrv17.exe
tomcat7.exe
tomcat8.exe
tomcat9.exe
When performing an installation, update or repair, the following executables should also be excluded (in addition to the above):
ActionAgentProc.exe
Setup.exe
Setupengine.exe
Note: After the upgrade / repair / modify is performed these rules can be removed
The following directories and subdirectories of these should be excluded from monitoring/scanning.
- %INSTALLDIR%\SAP BusinessObjects Enterprise XI 4.0\win32_x86
- %INSTALLDIR%\SAP BusinessObjects Enterprise XI 4.0\win64_x64
- %INSTALLDIR%\SAP BusinessObjects Enterprise XI 4.0\logging
- %INSTALLDIR%\SAP BusinessObjects Enterprise XI 4.0\java
- %INSTALLDIR%\SAP BusinessObjects Enterprise XI 4.0\data
- %INSTALLDIR%\SAP BusinessObjects Enterprise XI 4.0\FileStore
- %INSTALLDIR%\SAP BusinessObjects Enterprise XI 4.0\Auditing
- %INSTALLDIR%\sqlanywhere
- %INSTALLDIR%\tomcat\bin
- %INSTALLDIR%\tomcat\webapps
- %INSTALLDIR%\tomcat\work
- Input and output FRS if these are not in the default directories
- Webi Shared Document Cache (view properties of Web Intelligence Server for this information if it is set.)
Note that although for performance reasons it's recommended that active scanning of these files and directories be excluded during usual hours of operation and during report schedules, it is still recommended to run a full system scan during off peak hours/maintenance hours.
*Some components may or may not be included in your particular version of BI/BOE